Too many open files message after migrating CA IDM 14.3 cp1 from jboss 6.4 to jboss 7.2
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Too many open files message after migrating CA IDM 14.3 cp1 from jboss 6.4 to jboss 7.2

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Article ID: 186966

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

After migrating  CA IDM 14.3 CP01 from jboss 6.4 to jboss 7.2. When  trying  to start the server, getting too many files error. As per CA docs ulimit values should be set to 50000 but still same errors

 

Cause

Performance Tuning for JBoss or Wildfly is required.

Resolution

For JBoss or WildFly servers, set the Open Files (ulimit –n) to at least 50000 for the user that runs the JBoss or WildFly process.

Try setting the Ulimit value to 132K and this should work without any errors.

 

Have a look at the below files on your Linux servers:

If you don't see these properties, you can add them to the files.

Contact your Linux administrator for further assistance.

1. In /etc/security/limits.conf file add

<username> hard nofile <limitvalue>

<username> soft nofile <limitvalue>
  where <username>is the user (login user for JBoss or Wildfly)

 

2. In /etc/sysctl.conf file add

fs.file-max = 132000

 

These settings will require an OS restart in order to take effect.