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Sorting on the SystemUpTime attribute in the list view does not sort the models correctly in either ascending or descending order

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Article ID: 186930

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

While trying to sort a list of models in the list view using the SystemUpTime attribute in descending or ascending order was showing inconsistent results. 

Environment

Release : 10.3
Release : 10.4

Component : Spectrum OneClick

Cause

  This was an issue with the following entry in the table-model-config.xml file. 

    <text>

     <renderer>com.aprisma.spectrum.app.util.render.SysUpTimeRenderer</renderer>
    </text>

 

Resolution

Change the /$SPECROOT/custom/common/config/table-model-config.xml file and modify the following entry:

from:


System Up Time

<text>
     <renderer>com.aprisma.spectrum.app.util.render.SysUpTimeRenderer</renderer>
    </text>

 

to:


System Up Time

 

            <content>

                  <attribute>0x10245</attribute>

                    <renderer>com.aprisma.spectrum.app.util.render.SysUpTimeRenderer</renderer>

             </content>

Sorting by the SystemUpTime in ascending or descending order worked correctly after making the above change.