Layer7 API Gateway: After restoring a Gateway backup to another box, a non-existent node appears at "https://servername:9443/ssg/backup"
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Layer7 API Gateway: After restoring a Gateway backup to another box, a non-existent node appears at "https://servername:9443/ssg/backup"

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Article ID: 186866

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Updated On:

Products

CA API Gateway API SECURITY CA API Gateway Precision API Monitoring Module for API Gateway (Layer 7) CA API Gateway Enterprise Service Manager (Layer 7) STARTER PACK-7 CA Microgateway

Issue/Introduction

After restoring a Gateway backup to another box, the following issues occur:

When browsing to the backup I now notice that there is listed a gateway 2 button, the backup works from that, however not from gateway 1 button (routing timeout.


 https: // servername: 9443 / ssg / backup:

Environment

Release : 9.4

Component : API GATEWAY

Cause

The backup and restore is designed for the same machine, not really for migration.

The gateway configure file, and data in database, contain the info of the this machine, migrate these configure file and data usually causes problem.

The root cause of this problem is, the cluster_info table in the ssg database contains the nodeid, mac address, etc. of this gateway server, after migrate to new server, the new gateway will insert its info to this table, just like adding a new node to the cluster. But because the info of old server is still there, when browsing you see  2 gateway nodes, and one of them
is pointing to the old server which was shutdown, so it won't work.

Resolution

Be sure to have a recent backup or snapshot available before making any changes to the database.

Open the mysql command line and select the ssg database. You can manually empty the cluster_info table with the below query:

delete  from cluster_info;

restart gateway. (ie service ssg restart)

Now the data of nodes should be correct.