AWS Probe all of a sudden loses connection to all accounts one after another

book

Article ID: 186853

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

It seems all of a sudden the AWS probe just starts to lose connection to each account in the probe and we start to get the same error for each resource - that error being " Account Name is not responding(reason: connection and or inventory update failure){null}

aws.log errors:

Inventory update failed. Sending resource alarm
[Data Collector - xxxxx pxx-dev, aws] (1) error, Inventory update failed for xxxxx pxx-dev: null
....
Caused by: java.lang.NullPointerException
 at com.nimsoft.probe.application.aws.AWSProbe.getUpdatedInventory(AWSProbe.java:512)
 at com.nimsoft.probe.framework.genprobe.GenInventory.update(GenInventory.java:117)
 ... 14 more

and

Caused by: java.lang.NullPointerException
 at com.nimsoft.probe.application.aws.AWSProbe.getUpdatedInventory(AWSProbe.java:512)
 at com.nimsoft.probe.framework.genprobe.GenInventory.update(GenInventory.java:117)
 ... 14 more

and

[pool-10-thread-2, aws] S3Discovery::S3 GetBucketLocation Caught Exception for bucket [ S3Bucket [name=dev-actuarial-sagemaker-us-east-2, creationDate=Wed Jul 24 10:00:19 EDT 2019, owner=S3Owner [name=xxxxxxxxxAWS-LOB-INNOVATION-DEV,id=c83dd9b9b3a1b997a9b629552d3850xxxxxxxxx731a94d6b0f5f51d11b8683]] ] The authorization header is malformed; the region 'us-east-1' is wrong; expecting 'us-east-2' (Service: Amazon S3; Status Code: 400; Error Code: AuthorizationHeaderMalformed; Request ID: 5B5D16C05FAA0275)
Mar 02 14:53:52:397 [pool-10-thread-2, aws] com.amazonaws.services.s3.model.AmazonS3Exception: The authorization header is malformed; the region 'us-east-1' is wrong; expecting 'us-east-2' (Service: Amazon S3; Status Code: 400; Error Code: AuthorizationHeaderMalformed; Request ID: 5B5D16C05FAA0275), S3 Extended Request ID: 21lI95atJlkguJGTgpRjSSVYr9/Mxxxxxxxxuhs6gfFqT0QLLPwmCwB3QiqK2NgXSptdSl7HGw=
 at com.amazonaws.http.AmazonHttpClient$RequestExecutor.handleErrorResponse(AmazonHttpClient.java:1586)
.....

Cause

- Unknown, no longer occurring.

Environment

Release : 9.0.2

Component : UIM - AWS

Resolution

The issue of the aws probe losing connection to all accounts one after another is no longer occurring so it may be assumed that the problem originated within AWS itself for the given AWS accounts.