Jobs stuck in Running/READY state in VMWare VMotion (CA WA Agent)
search cancel

Jobs stuck in Running/READY state in VMWare VMotion (CA WA Agent)

book

Article ID: 186801

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent Autosys Workload Automation

Issue/Introduction

After a VM is moved the WA Agent jobs appear to have been stuck.

Environment

Release : Any

Component : CA Workload Automation System Agent

Cause

When VMotion is moving the VM to new ESX host, everything is halted.  The memory, virtual CPU etc. are started backup on the new host once the VM has been fully moved.  Services in Windows OS usually tend to recover from the holding state.  In some cases the services including WA Agent may lose connections as the VMotion has to move the network connections to new switches.

Resolution

After the VM has been moved, shutdown restart the agent.  This will likely restore the connections quickly and manager/scheduler will get updates on the job status.

Note: If for some reason the jobs are not recovered or have failed due to moving of VM, then you may need to force complete it and submit it again.