CSRF Error when saving Data Identifier
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CSRF Error when saving Data Identifier

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Article ID: 186615

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Updated On:

Products

Data Loss Prevention Network Protect

Issue/Introduction

When editing a policy, Enforce user is presented with no error and kicked out of the Enforce UI.
When editing a data identifier tied to the same policy user is kicked out with CSRF Protection warning

Environment

Release : 15.5

Component :Data Loss Prevention Enforce

Cause

By Default Apache Tomcat has an HTTP Post limit of 2048KB(2mb) 
In earlier versions of Tomcat this could be bypassed by setting maxPostSize="0" (Apache 6 and earlier)
In newer version of Tomcat this can be bypassed by setting maxPostSize="-1" (Apache 7 and later) 

Resolution

Open server.xml located in <DLP HOME>\EnforceServer\15.5\Protect\tomcat\conf\server.xml
Add "maxPostSize="-1" to the 'Connector' Line
Example:

<Connector SSLEnabled="true" URIEncoding="UTF-8" acceptCount="100" disableUploadTimeout="true" enableLookups="false" maxThreads="150" port="443" scheme="https" secure="true" maxPostSize="-1">

Save the file and restart SymantecDLPManagerService.