SQL Agent: Errors with Agent Type Oracle doesn't match ORACLE OCI
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SQL Agent: Errors with Agent Type Oracle doesn't match ORACLE OCI

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Article ID: 186578

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

The SQL Agent job fails to start.  

Possible errors:  

1. Agent DB-Type 'ORACLE' doesn't match Connection DB-Type 'ORACLE_OCI'

Issue occurred after upgrading to 12.3 from 12.2, jobs were failing where the connection was set to Oracle.
Changing these to Oracle_OCI fixed those but some jobs still fail when the connection is set to Oracle_OCI.
Other jobs with the same connection and agent and almost the same SQL work.  On rolling back to the previous 12.2 agent this works.

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or

2. IO Error: Invalid connection string format, a valid format is: "host:port:sid" 

when the Agent is configured to use Oracle OCI interface rather than JDBC (useOraClient=1).

According to the documentation (see link below) it is possible to define just the TNS identifier to get the job working. Jobs taking advantage of this will fail in version 12.3.

Environment

Release: 12.3.0 to 12.3.3

Component: AUTOMATION ENGINE

Cause

SQL AGENT is not using USEORACLIENT parameter since LICENCE check was removed

Resolution

Workarounds

In case of error 1:

This applies when your Agent is still using ORACLE while the connection object is using ORACLE_OCI.

In the Agent .ini file, open and look for "useOraClient="

By default, this is set to 0 (which is for ORACLE) but the fact that the error message mention you are using ORACLE_OCI.

In that case, change that value to 1, so it specifies useOraClient=1

Then, stop and restart the agent.

 

In case of error 2:

There's no other workaround than downgrading the Agent to 12.2.0.

 


Solution: This was fixed with the database agent on 12.3.4