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nimSession - failed to connect session error code 10061 (Windows)

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Article ID: 186574

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Updated On:

Products

NIMSOFT PROBES DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

During startup of the Nimsoft robot, the Controller probe might report 10061 in the controller.log: 

Controller error:
Controller: Controller on 5384631-2422648 port 48000 started
Controller: Hub ATL_NMHUB01(xxx.xx.xx.xx) contact established
Controller: nimSession - failed to connect session to xxx.xx.xx.x:48001, error code 10061
Controller: nimPostMessage: sockConnect failed.
 

Cause

This is part of normal operations during the startup process, as the spooler has not had time to initialize yet. It happens if you turn audit on and when unable to send the audit message to the spooler, the controller will send the message directly to the hub.

Environment

Component : CAUIM

hub

robot

Resolution

‚ÄčThis is not an error and the messages can be safely ignored.

Additional Information

10061 is a Connection Refused error sent to you by the server. You could not make a connection because the target machine actively refused it. The most common cause is a misconfigured server, full server, or incorrect Port specified by the client.