Task Servers are unable to register after migrating to a new SMP: The handler 'RegisterTaskServer' is failed to process request.
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Task Servers are unable to register after migrating to a new SMP: The handler 'RegisterTaskServer' is failed to process request.

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Article ID: 186499

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

The problem started after trying to migrate their Site Servers from an old Notification Server to a new one.

This migration included moving a few Site Servers from an old SMP to a new one. The Site Server was able to get the policy to upgrade the Altiris Agent and the Task Service plugin. Both the agent and the task service plugin are in the same version as the SMP. The Site Servers were being moved from SMP 8.1 RU7 to SMP 8.5.

The following error entry can be found on the agent logs from the Site Servers:

"Failed to perform re-register.
Error response returned from server: The handler 'RegisterTaskServer' is failed to process request. Registration of unsupported Task Server <Task Server GUID> version '8.5.3035.0' is rejected (expected version is '8.1.6236.0'). Please upgrade it or re-target it to another Notification Server that supports specified version of Task Server."

Removing and installing the Task Service on the affected machines seems to solve the issue.

There were more than 120 Site Servers and it was not possible to reinstall the service manually on all of them.

Environment

ITMS 8.x

Cause

In this particular scenario, there was a manual reference for the "PreferredNSHost" under the Task Service Setting on the new SMP (since they migrated the same database to the new server) that was still referencing the old SMP. That is why the error message was saying that these Task Servers were trying to register to the SMP 8.1 rather than the SMP 8.5.

Resolution

SMP 8.5 and later:

  1. In the SMP Console go to "Settings > Notification Server > Site Server Settings > Task Service > Settings".  Select the policy that targets the problem Tasks Server.
  2. Under "Communication Profile", check that the checkbox option "Use an alternate URL for the Task Server to access the NS" is not selected (if you used to have a "PreferredNSHost" reference, it is most likely this checkbox is selected and referencing to the old SMP Communication profile). 

  3. If it is checked, unchecked so the default new SMP one can be used.
  4. On the Task Server open "Services Manager" and restart the "Altiris Client Task Data Loader" service
  5. Open the Symantec Management Agent UI and click on the Update Configuration button.

ITMS 8.5 and earlier:

  1. On the SMP server open ".\Program Files\Altiris\Notification Server\bin\Tools\NSConfigurator.exe
  2. Search for TaskServiceAdvancedSettingsAllowed. Enable the setting and save (set it to "True").
  3. In the SMP Console go to "Settings > Notification Server > Site Server Settings > Task Service > Settings".  Select the policy that targets the problem Tasks Server.
  4. The Advanced Settings page should be visible. Look near the bottom for the "Preferred host" box and verify the name of the server is the current SMP and not another one.  If it is incorrect make the necessary changes and save it.


  5. On the Task Server open "Services Manager" and restart the "Altiris Client Task Data Loader" service
  6. Open the Symantec Management Agent UI and click on the Update Configuration button.

Additional Information

169693  Client Task Server failed to complete registration


172503  Clients are unable to register or connect to a new Task Server