Unable to perform event actions on jobs in QuickView after changing the EiamAdmin password in EEM
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Unable to perform event actions on jobs in QuickView after changing the EiamAdmin password in EEM

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Article ID: 186439

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Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys) Autosys Workload Automation

Issue/Introduction

After changing the EiamAdmin password in EEM, users are no longer able to access any of the event actions such as Force Start or Send Event in QuickView. The following error is observed in <WCC_HOME>/log/CA-wcc.log when a user selects a job in QuickView...

2020-03-05 13:01:43,433 @resources < USER1 ~B44> [] ERROR #AccessFacade                       # Cannot check permission for SARResourceClass=as-sendevent, ResourceName=ACE, Action=set_global

java.lang.RuntimeException: can not establish context

Environment

Release: All Supported Versions
Component: CA Workload Control Center

Cause

When the EiamAdmin password is changed in EEM, you must update the EEM server definition in WCC with the new password. Otherwise, WCC will no longer be able to access the WorkloadAutomationAE application in EEM to check as-sendevent access for a user, which is required to get access to event actions in QuickView.

Resolution

Follow the steps from this link to update the EEM server definition in WCC with the new password for EiamAdmin...

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/intelligent-automation/workload-automation-ae-and-workload-control-center/11-3-6-SP8/administrating/ca-wcc-administration/administer-the-configuration-batch-interface.html#concept.dita_834f26aa195a4f1412af52b2a8559253986a5b4b_UpdatetheCAEEMServerDefinitioninCAWCC

To update the CA EEM server definition in CA WCC, use the following command syntax:

wcc_config -u user_name -p password --eemhostname eem_host_name --eemadmin eem_administrator --eempassword eem_password [--eemappid eem_application_id] [--eemcertname eem_certificate_name] [--eemcertkey eem_certificate_key]