We have a number of nnnnnnnnnnnnn.data.bad files in our smartstor folder What should we do with these files?
-rw-r----- 1 caapm10 web 217968640 Feb 11 23:10 1581454815000.data.bad -rw-r----- 1 caapm10 web 126824448 Feb 12 21:05 1581534015000.data.bad -rw-r----- 1 caapm10 web 69279744 Feb 12 23:03 1581541215000.data.bad -rw-r----- 1 caapm10 web 39833600 Feb 13 00:04 1581544815000.data.bad -rw-r----- 1 caapm10 web 233697280 Feb 13 19:06 1581613215000.data.bad -rw-r----- 1 caapm10 web 70221824 Feb 13 21:04 1581620415000.data.bad -rw-r----- 1 caapm10 web 58699776 Feb 13 23:04 1581627615000.data.bad
Environment
Release : 10.x
Component : APM
Cause
Data files are flagged as bad when a corruption is detected in the file by the Enterprise Manager. The file is then renamed and ignored. This problem is usually caused when file system problems are encountered such as disk errors or file system full situations.
Resolution
First identify any underlying cause by reviewing the IntroscopeEnterpriseManager.log files - if the reason is not obvious then raise a case with support for assistance.
Once the cause has been identified and resolved then as it is not possible to repair these files the only action is remove them.