Unable to login to admin console after changing database port

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Article ID: 186241

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Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

We changed the database port from 1433 to 3000 and are unable to login to Admin console after that. 

Cause

wasp on primary hub is still trying to connect to port old port 1433:

Mar 09 13:59:02:530 ERROR [http-bio-443-exec-8, com.nimsoft.nimbus.probe.service.wasp.auth.LoginModule] login() org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (The TCP/IP connection to the host XXXX, port 1433 has failed. Error: "connect timed out. Verify the connection properties, check that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port, and that no firewall is blocking TCP connections to the port.".)

The root cause seems to be corrupted files in the temp directory.

Environment

Release : 8.5

Component : Admin Console

Resolution

On primary hub: 
1)deactivate wasp 
2) delete contents of c:\windows\temp or /tmp 
4) edit  wasp .cfg and set the connection = to blank. IE remove everything to the right of the =
5) save the file
6) restart wasp.

Additional Information

The other components that connect to the database and can face similar issues are nas, cabi and Unified Reporter