Spectrum device model interfaces do not match the device interface configuration
search cancel

Spectrum device model interfaces do not match the device interface configuration

book

Article ID: 186162

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Spectrum device model interfaces do not match the device interface configuration

Environment

Release : All Supported Releases

Component : SPCCSS - Spectrum Core / SpectroSERVER

Cause

The device configuration has changed but the model in Spectrum has not been reconfigured to sync with the device configuration.

Spectrum can detect an interface configuration change on a device model and automatically reconfigure the device model to be in sync with the configuration on the device. Please reference knowledge article 132935 "Device Reconfiguration" for details.

However, if there is no change in the ifNumber, ifTableLastChange or ifStackLastChnage attributes, Spectrum will not automatically reconfigure the device model.

Resolution

1. Ensure the "Automatically Reconfigure Interfaces" parameter in the Reconfiguration subview of the model is set to Yes

2. Check the device to see if it is configured to update the ifNumber, ifTableLastChange and/or ifStackLastChnage attributes when a configuration change is made.

3. If this is a Cisco device, the device may have gone through a re-indexing of the interfaces where the ifNumber, ifTableLastChange and/or ifStackLastChnage attributes do not change. If this is so, you can configure the Cisco device to not re-index the interfaces. Please reference "Interface Index (ifIndex) Persistence" for more information.