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New UX Timesheet grid slow performance when doing Group By with large data

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Article ID: 186087

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

A message appears: Loading data… Please Wait. The loading never completes.

STEPS TO REPRODUCE:

  1. Make sure you have a large number of timesheets
  2. Log in to the New User Experience (UX)
  3. Go to the Timesheets grid with access to many timesheets
  4. Once you open the Grid, click on the Status column hamburger menu and select Group By Status

Expected Results: To be able to see the timesheets return Grouped in a timely manner.

Actual Results: Loading data… Please Wait message, the loading never completes.

No matter how much data is returned, the filter Group By never completes

Cause

This is caused by DE53847

Environment

Release : 15.7.1, 15.8

Resolution

Fixed in Clarity 15.8.1

Workaround: Avoid using Group By on previous releases