DE53847 Slow performance when doing Group By in New UX Timesheet Grid with large dataset

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Article ID: 186087

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

STEPS TO REPRODUCE:

  1. Connect to a large customer dataset (use environment below)
  2. Go to New UX - Open Timesheets grid with a user with access to many timesheets (use indicated users below)
  3. Once you opened the Grid, click on the Status column hamburger menu and select Group By Status

Expected Results: To be able to see the timesheets return Grouped in a timely manner.

Actual Results: Loading data… Please Wait message, the loading never completes.

No matter how much data is returned, the filter Group By never completes

Workaround: None

Cause

This is caused by DE53847

Environment

Release : 15.7.1, 15.8

Component : CA PPM APPLICATION

Resolution

This is fixed in Clarity PPM 15.8.1

We suggest to avoid using Group By on previous releases