Installing Endpoint Protection on macOS 10.15.4/10.16 results in a 'Legacy System Extension' warning.

book

Article ID: 186024

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

Installation of Symantec Endpoint Protection (SEP) for Mac on a pre-10.15.4 macOS system, which is then upgraded to 10.15.4 or newer will prompt the end-user with a warning message about a Legacy System Extension that will be incompatible in future releases of macOS.

Cause

Apple is dropping kernel extension support in 10.16.

Environment

macOS 10.15.4+

Resolution

End-users will want to click 'OK' on the warning prompt. This is expected behavior with 14.2 RU2 and 14.2 RU2 MP1 releases due to Apple dropping kernel extension support in 10.16.