Sometimes (random issue) getting EE_AUTHFAILED error trying to login. EEM setup for failover.

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Article ID: 186005

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Updated On:

Products

CA Service Management - Service Desk Manager ServiceDesk Server Management Suite

Issue/Introduction

Environment:

ServiceDesk 17.2
2 EEM nodes setup for failover.


Issue:

Some times login does not work and EE_AUTHFAILED error authenticating user is reported.

In stdlogs:
Nodename bopauth_nxd          6884 ERROR        eiamAuth.c             477 Error authenticating user: 'username' - EE_AUTHFAILED Authentication Failed success - took '31' miliseconds.


In EEM logs:

TRACE [0x0000282c] [PozFactory] PozFactory::attachPoz - Leave : retval 1
INFO [0x0000282c] [PozFactory] PozFactory::setFailover: failover set to server [EEMsecondaryserver]
ERROR 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] PozFactory::isFailoverRequired: Could not communicate with the EEM Server, server returned with errorcode= 704
WARN 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] Network::RunPrivilegeMethodV aginst [host EEMprimaryserver sponsor iPoz method GetUserSession] was not successful. [error code = 704] [ error = failed to create user profile]
TRACE 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] PozFactory::setFailover(hostname) - Enter : args [Hostname=EEMprimaryserver
WARN 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] Backend server EEMprimaryserver couldn't be contacted.
TRACE 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] PozFactory::setFailover - Enter : args [Status=1]
TRACE 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] PozFactory::setFailover - Leave
WARN 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] PozFactory::setFailover: EEM server will try to failover in following order [EEMsecondaryserver EEMprimaryserver ]
TRACE 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] PozFactory::attachPoz - Enter
DEBUG 2020-02-14 09:37:52,684 [0x0000282c] [PozFactory] PozFactory::attachPoz - Calling ispUtil::BuildFilter : params [ProductInstance=PozAdmin]

Cause

Incorrect settings in option manager variable eiam_hostname

Environment

Release : 17.2

Component : SERVICE DESK MANAGER

Resolution


The environment variable  NX_EIAM_HOSTNAME need to be set with the name of the 2 EEM servers (separate the names with comma) i.e.

@NX_EIAM_HOSTNAME=EEMprimaryserver,EEMsecondaryserver

To do the change in the option manager for the variable eiam_hostname, you need to follow the steps as per the ServiceDesk architecture setup (Advanced Availability or Conventional). Check the documentation for your ServiceDesk release and verify that the variable is correctly setup in the NX.env file for all the ServiceDesk servers.

Additional Information

Instructions to verify EEM failover :

https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=37336