Alarm suppression - All devices in a location are Down and are Suppressed without having an Alarm created
book
Article ID: 185984
calendar_today
Updated On:
Products
CA SpectrumDX NetOps
Issue/Introduction
When NetOps Spectrum loses connectivity to a group of connected devices it is unable to determine the root cause of the network outage. In this case, the status of all devices affected by the outage is set to gray, and a red 'Unresolved Fault' alarm is generated. (Typically the inability to determine the cause is due to network devices between the SpectroSERVER and target group of devices not existing in the landscape. This is usually due to the traffic passes through an ISP, a Client's network for which access is not available).
In cases like this, an 'Unresolved Fault' alarm is either generated on the 'Fault Isolation' application model or on a device within the fault domain (a fault domain is a group of connected devices). In this specific case the Unresolved Fault event was generated but an alarm was not produced.
Environment
Release: Any
Cause
The 0x10d05 event responsible for generating the Critical Unresolved Fault alarm had been customized to not alarm. This resulted in the group of devices all being suppressed without an alarm to signify the outage.
From the $SPECROOT/custom/Events/EventDisp file
Resolution
Restore the Unresolved Fault event to again alarm by removing the entry from the $SPECROOT/custom/Events/EventDisp file.
The default out of the box definition is located in $SPECROOT/SS/CsVendor/Cabletron/EventDisp
Additional Information
The Event and Alarm Customization section of the NetOps Spectrum documentation lists the events that should not be modified due to fault isolation.