Device context report Alarm View fails with error in Performance Management

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Article ID: 185815

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Alarm View for device context report fails with an error.

Alarm View in regular Dashboards fail with the same error if they are fixed to a specific Device with >150 component items as context.

Alarm View in regular Dashboards work without error when set to a Group with 1 or more items as members.

The View shows an error message that states:

An unexpected error has occurred. Please check the logs for any error messages.

At the same time, in the PCService.log file located in (default path) /opt/CA/PerformanceCenter/PC/logs, we see the following error:

ERROR | Model-Invoker-7 | 2020-02-20 08:12:15,608 | com.ca.im.portal.plugins.spectrum.models.AlarmViewTableModel | Failed to make request: Error.SearchQueryCombinationsExceedStackProcessingSize

Cause

The RESTful web services query used for Alarm Views in the device context dashboard requests all active alarms for the device and it's component items.

When the device has >150 items resulting in >150 model_handle values sent in the request, it violates the hard coded limit for the Spectrum RESTful query used.

Environment

Performance Management releases r3.7.10 and earlier

Resolution

This issue has been fixed in CA Performance Management 3.7.11.

Symptom: When a device has more than 150 interfaces the Alarms View on Alarms tab of device context page fails with error, "An unexpected error has occurred".
Resolution: Addressed issue that Alarms View on Alarms tab of device context page fails with error when a device has more than 150 interfaces.
(3.7.11, DE450059)

As a workaround use Alarm based Views added to Dashboards. Set them to a Group Context via the Views configuration itself, or via the Dashboard level Context settings.

If the Alarm based Views added to a Dashboard are set to a specific Device for the Context, if that device has more than 150 interfaces it will generate the same problem. This is true whether setting the Context at the Dashboard or View Configuration level.

Additional Information

See the fixed issues documentation for this and other fixed defects:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/performance-management/3-7/release-notes/fixed-issues.html