How to determine if a metric is supported
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How to determine if a metric is supported

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Article ID: 185780

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

I have metrics that show as "not supported" in Performance Management.  Can you explain why a metric is not supported as opposed to supported?

Views show Metrics as Not Supported.

Device has a Metric Family listed in Polled Metric Families but no Vendor Certification is set.

Environment

All supported DX NetOps Performance Management releases

Cause

Device does not support the MIB OIDs required by the Vendor Certifications involved.

Resolution

You must check the internal name of the backing vendor cert of the "not supported" metric.  

This can be done when there is no Vendor Certification listed against the device for the Metric Family. Simple follow the same steps for the Vendor Certification in the Metric Family we'd expect to be supported.

To do this do the following:

1. Pick a device under Monitored Inventory > Monitored Devices
2. Go to the Polled Metric Families tab
3. Note what is seen under the "Vendor Cert" column
4. Go to Monitoring Configuration > Vendor Certifications
5. Put your mouse on the "Name" column > click the gear icon > Columns > Check the box for "Internal Name"
6. Go to http://DA:8581/typecatalog/certifications/snmp/<Internal Name>
7. Note the <IsIndex>true</IsIndex> OIDs.  For example:

<Attribute name="Index" type="ObjectID">
<Documentation/>
<IsKey>true</IsKey>
<IsIndex>true</IsIndex>
<Source>1.3.6.1.4.1.2011.5.25.32.2.1.1.5</Source>
</Attribute>

There could be just 1, or there could be several.  For this example we are only looking at 1

8. Log on to the collector that owns the device and attempt to do an snmpgetnext against the OID

For Example:

snmpgetnext -v2c -c<community> <IP Address> 1.3.6.1.4.1.2011.5.25.32.2.1.1.5

Is the result you get back part of the table you are querying?  If it is, the metric should be supported.  If it returned another table's entry that exists after the OID we're asking about, then the table is empty and the metric will not be supported

Additional Information

A vendor cert could have 1 <IsIndex>true</IsIndex> OID or it could have many.  If it has say 3, then all must be supported by the device in order for the metric to be supported.  If only 2 out of the 3 are supported then the metric is not supported in Performance Management