Clarity PPM Upgrade fails with Error Applying XOG: Failure occurred while applying API_ADMIN.xml

book

Article ID: 185509

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

  1. Clarity PPM Upgrade fails with below referenced in install.log:

3/02/20 6:54 PM (ExecTask) Error Applying XOG: Failure occurred while applying API_ADMIN.xml

3/02/20 6:54 PM (ExecTask)  Check <Clarityhome>/runtime/clarity/logs/xog-seeddata/out/nsa/API_ADMIN_out.xml for errors

  1. When checking the API_ADMIN_out.xml file referenced in the above error the below error is seen:

SQL Exception with error code : 1 message: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-00001: unique constraint (NIKU.CMN_AUDITS_PK) violated ORA-06512: at "NIKU.T_RESOURCE_SSRM_RESOURCES", line 29 ORA-04088: error during execution of trigger 'NIKU.T_RESOURCE_SSRM_RESOURCES'

Note: The xml file can be found on the Clarity server in the path mentioned in the first error

Cause

This issue is due to auditing enabled during the upgrade which is recommended to be turned off on all objects prior to upgrade.

Environment

Release : All supported Releases

Component : CA PPM APPLICATION

Resolution

1. Roll back the environment to prior to upgrade
2. Disable/turn off all auditing
See steps at: KB 102304 - How to proceed if you have auditing enabled in order to upgrade CA PPM (how to disable auditing)
3. Rerun upgrade