Test NCM SSH device config capture in Command Line - NCM capture troubleshooting

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Article ID: 185362

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Updated On:

Products

CA Spectrum

Issue/Introduction

We are seeing errors when attempting to use NCM to capture a device configuration over SSH. What are some basic troubleshooting steps to perform? 

Cause

There are a number of reasons why a NCM capture may fail. Here are some options to test the capture in various methods to start narrowing down where the issue may be. 

Environment

Release : 10.3

Component : SPCAPP

Resolution

1. Test the SSH script via command line: 

- You can export the script from the NCM Device Family information tab settings - export the SSH script file to <SPECROOT>/bin
- The default out-of-box SSH scripts available to use show their command-line usage within the script - if you are using custom scripts you may or may not have this usage defined.

Example: 

capture_running.pl <device IP> <user> <pass> <enable_pass><login_timeout_in_seconds> <capture_timeout_in_seconds>

e.g.:

Scrip export example: 



2. Collect a sniffer trace of the attempted capture

- run Wireshark Sniffer or TCPdump or similar to capture packet traffic while attempting the capture
- do this when testing the capture from within OneClick as well as testing from SSH script in command line for comparison on both methods

3. Enable NCM capture debug

- nav to <SPECROOT>NCM
- edit the config.xml file
- scroll to the bottom of the file and set the following parameters: 

 <debugging type="java.lang.String">max</debugging>
    <diff-largefile type="java.lang.String">on</diff-largefile>

- save the config.xml file, and restart the ncmserv.exe process for the changes to take effect
- attempt a capture and review the <SPECROOT>/NCM/logs/debug files 
- also review the ncmservice log at <SPECROOT>/NCM/NCMSERV.OUT


4. Increase DCM Timeout for the device

- If after testing the above troubleshooting steps and still unable to determine cause for a failed capture, also try increasing DCM timeout for the device
- While this settings is adjusting SNMP poll timeout, it also affect NCM captures
- max value 60,000 ms

Additional Information

- If after checking the above troubleshooting options and still unable to determine the issue, then we recommend to open a case on it 
- Please provide the following details: 

- screenshot of the capture error
- the Sniffer trace / PCAP file of the capture attempt
- copy of the SSH script if it is custom
- collect the NCM directory logs <SPECROOT>/NCM
- collect the OneClick tomcat logs <SPECROOT>/tomcat/logs
- verify running Spectrum version <SPECROOT>/Install-Tools/.history

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