Not able to clear Enddate from Oracle Apps endpoint using PX
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Not able to clear Enddate from Oracle Apps endpoint using PX

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Article ID: 185180

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Updated On:

Products

CA Identity Manager CA Identity Portal CA Identity Suite

Issue/Introduction

We are using the Oracle Apps connector to provision the users from IM to Oracle Apps endpoint.
We are facing an issue where Enddate in Oracle Apss endpoint is not getting cleared by PX policies.

We have created a PX policy and in the Action rule we are removing the Enddate directly in Oracle Endpoint. Policy is triggered correctly but the Enddate is not cleared.
We are able to clear this field when editing the account directly using IMPM (Provisioning Manager).

Environment

Release : 14.x

Component : IdentityMinder(Identity Manager)

Cause

Reviewing the logs we can see that, when utilizing IMPM, the value is being set to 0
WARNING eTFNDDirectory::######- CFndTarget::SetColumnValue(): Unicenter date set to 0. Skipping....

While utilizing PX, it is trying to delete the current value, then add a new one
ERROR eTFNDDirectory::######- CFndTarget::SetColumnValue(): MOD_DELETE: Unhandled sqlType (9)
ERROR eTFNDDirectory::######- CFndTarget::SqlUpdateUserAolOnly(): SqlColumnValue() failed with ''

The endpoint cannot handle the NULL value therefore operation is failing.

Resolution

Via PX, use and set the value "0" to reset end date