Apply 14.1 CP 02 for Windows Endpoint on CAM PAM SC Enterprise Management Server

book

Article ID: 185174

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM) CA Privileged Access Manager - Cloakware Password Authority (PA) PAM SAFENET LUNA HSM CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

OS: Windows 2016

CA PAM SC Endpoint - 14.1 CP 02

We are able to upgrade Windows Endpoint from 14.1 to 14.1 CP02 using - PAMSC_DE437870_SC141CP2_14.10.0.1265_WINDOWS.

Can we use this same setup to upgrade the PAM SC running on Enterprise Management from 14.1 to 14.1 CP02.

Does this will have any impact on other Enterprise Management Components such as WildFly and ActiveMQ?

Environment

Release : 14.1

Component : PAM SERVER CONTROL ENDPOINT

Resolution

1) Below are the guidelines for upgrade or migration from older release to 14.1 release of CA PAM SC endpoint application.

2) https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-privileged-access-management/privileged-access-manager-server-control/14-1/upgrading/upgrade-or-migrate-an-endpoint.html

3) The PAM SC Server component as well has the PAM SC endpoint application embedded internally, the upgrade process of embedded endpoint is not currently documented, hence it's not possible to comment upon the impact of the upgrade on ActiveMQ or WildFly applications.

4) The embedded internal PAM SC endpoint is technically the same as independent endpoint and it as well has to communicate with the PAM SC server / Distribution server to be able to get the updates, the upgrade should be possible and needs to be performed upon client's own risk.

Additional Information

If possible, take a complete snapshot of the PAM SC server as well as the database server before performing any upgrade activity. Snapshot is possible only if the PAM SC server is a Virtual Machine.