No Data in Analytics Dashboard
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No Data in Analytics Dashboard

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Article ID: 185162

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Updated On:

Products

CA API Developer Portal

Issue/Introduction

The portal analytics dashboard shows no data. The below message is seen in Jarvis container log:

Failed to send document back to kafka:org.I0Itec.zkclient.exception.ZkTimeoutException: Unable to connect to zookeeper server 'zookeeper1:2181' with timeout of 8000 ms

Environment

Release : All supported versions

Component : API PORTAL

Cause

 DNS delay - one of the many possible reasons

Resolution

Run the following command to check for any DNS delay:

  • docker exec -it -u 0 $(docker ps --filter name=portal_dispatcher -q) /bin/bash -c "time nslookup zookeeper 127.0.0.11"

If the output shows a delay of more than a few seconds, then follow these steps to fix it.

 

Try disabling any custom settings in /etc/resolv.conf file and test the above command again. If there is still a considerable delay then add this line in /etc/resolv.conf file:

  • options timeout:1 attempts:1

Additional Information