Getting 'DownloadFile - No response was received during the time-out period for a request' in the logs when trying to load the Product Listing on SIM.
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Getting 'DownloadFile - No response was received during the time-out period for a request' in the logs when trying to load the Product Listing on SIM.

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Article ID: 185127

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Updated On:

Products

IT Management Suite

Issue/Introduction

After installing Symantec Installation Manager (SIM), when SIM is preparing to load, it just hangs in a "Preparing" state. SIM doesn't open or take a long time to load.

The SIM logs (usually under C:\Program Data\Symantec\SMP\Logs) shows the following:

Priority: 4
Date: 4/2/2009 11:42:54 AM
Tick Count: 3278921
Host Name: MachineName
Process: SYMANT~1 (4628)
Thread ID: 7
Module: SYMANT~1.EXE
Source: Symantec.Installation.FileDownloader.DownloadFile
Description: DownloadFile - Downloading file from 'http://www.solutionsam.com/solutions/pl/symantec.pl.xml' to 'file:///C:/Program Files/Altiris/Symantec Installation Manager/Installs/Altiris/symantec.pl.xml__tmp'

Followed by:

Priority: 1
Date: 4/2/2009 11:42:54 AM
Tick Count: 3378937
Host Name: MachineName
Process: SYMANT~1 (4628)
Thread ID: 7
Module: SYMANT~1.EXE
Source: Symantec.Installation.FileDownloader.DownloadFile
Description:
DownloadFile - No response was received during the time-out period for a request.

( Exception Details: System.Net.WebException:
The operation has timed out
   at System.Net.HttpWebRequest.GetResponse()
   at Symantec.Installation.FileDownloader.DownloadFile(Uri sourceUri, Uri destinationUri, Int64 fileSize) )
( Exception logged from:
   at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
   at Altiris.Diagnostics.Logging.EventLog.ReportException(String strMessage, Exception exception)
   at Symantec.Installation.FileDownloader.DownloadFile(Uri sourceUri, Uri destinationUri, Int64 fileSize)
   at Symantec.Installation.FileDownloader.DownloadFiles()
   at Symantec.Installation.Context.ProductListingManager.DownloadPlFile(String source, String destination)
   at Symantec.Installation.Context.ProductListingManager.GetAndValidateLatestPlFile(String source, ProductListingInfo& plInfo, Boolean& nofileretrieved)
   at Symantec.Installation.Context.ProductListingManager.GetAndReadLatestProductListingFile(String source, ProductListingInfo& info)
   at Symantec.Installation.Context.ProductListingManager.LoadProductListing()
   at Symantec.Installation.Context.ProductListingManager.PlLoadAndUpdate()
   at Symantec.Installation.Context.ProductListingManager.<BeginPlLoadAndUpdate>b__0()
   at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
 )
( Extra Details:  Type=System.Net.WebException Src=System )


If you browse from the server to 'http://www.solutionsam.com/solutions/pl/symantec.pl.xml', you will be able to open the page just fine but for some reason, you can't download the file. You even checked the Proxy settings and everything seems to be fine.

Cause

Firewall on the Server was blocking the download of the product listing file (symantec.pl.xml). That is the reason why the SIM logs were displaying 'No response was received during the time-out period for a request.'. It was timing out.

Resolution

In this case, make sure to check your firewall settings. After the customer loaded a firewall client on the server, it solved the problem by configuring their firewall settings.