Running software delivery tasks as part of a job on the computers without Software Management Solution plug-in or on unmanaged computers fail
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Running software delivery tasks as part of a job on the computers without Software Management Solution plug-in or on unmanaged computers fail

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Article ID: 184988

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Updated On:

Products

Software Management Solution

Issue/Introduction

It is not possible to run software delivery tasks as part of client jobs on the computers that have no Software Management Solution plug-in installed or on unmanaged computers. Such computers are excluded from the target during the task or job instance creation.  You might see an error similar to:

 "Failed to obtain a Software Management Solution license. Either Software Management Solution Plug-in is not installed on the computer or if it is installed, the inventory data is not yet updated on Notification Server".

Cause

In Software Management Solution 8.1 and greater, the following changes are introduced:

  • You can run the Quick Delivery and Package delivery tasks as part of a job only on the computers without Software Management Solution plug-in.

  • You can run the Quick Delivery and Package delivery tasks as part of a job only and only once on the computers without the Symantec Management Agent (unmanaged computers). For example, you can run these tasks as part of Deployment Solution imaging jobs that install the required agents and plug-ins.

Before you use this functionality, consider the following:

  • Despite the availability of this functionality, Symantec recommends installing the Symantec Management Agent and Software Management Solution plug-in on every computer where you want to run software management tasks.

  • You cannot run software delivery tasks as standalone tasks on the computers that have no Software Management Solution plug-in installed or on unmanaged computers.

  • This functionality is not available out of the box and not enabled by default. You must enable it manually by setting the following coreconfig as explained below.

Resolution

 

For 8.5 and newer versions:

  • Settings> Notification Server> Core Settings
  • Then right click on the '+' button to 'Add New Core Settings'
  • Create the following core settings and test again
    • SmsAllowJobTargetingToNonLicensedComputers  Value: True



 

In older versions, we don't have the 'Core Settings' in the console and the following registry key should be created manaully
     <customSetting key="SmsAllowJobTargetingToNonLicensedComputers" type="local" value="True" />.

 

NOTE: If you manually modify this file you might consider making a backup of it before making any changes.

      • Including a computer without Software Management Solution plug-in to the job target causes the Software Management Solution license consumption for that computer.
        NB! You cannot automatically reclaim the license for a computer that does not succeed to install Software Management Solution plug-in as a result of running the imaging job with a Quick Delivery or Package delivery task. To reclaim it, you need to remove it manually from the SmfQuickDeliveryLicensing table during the license synchronization process that reclaims the licenses for the deleted, unmanaged, or retired computers in your environment or for the active computers without Software Management Solution plug-in.

      • Including an unmanaged computer to the job target does not cause the Software Management Solution license consumption for that computer.

Additional Information

In at least one instance we have seen this play a role in Deployment Solution when combining preboot Deployment tasks with Software Delivery tasks in the same job on unmanaged endpoints. Since the pectagent can't pull a Software license the job would fail immediately even though the first set of tasks were strictly DS related.