Error: Management Exception details: code=InvalidClass (0x80041010)
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Error: Management Exception details: code=InvalidClass (0x80041010)

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Article ID: 184940

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Updated On: 02-21-2025

Products

IT Management Suite

Issue/Introduction

The following error entries were seen in the NS logs after trying to repair the Symantec Management Platform (SMP):

Service check failed for: AeXSvc

Invalid class 
   [System.Management.ManagementException @ System.Management]
  ....omitted....

Management Exception details: code=InvalidClass (0x80041010)

Exception logged from: 
   at Altiris.NS.SupportServices.ServiceMonitor.CheckServices(System.Threading.Thread, Int32,

....omitted....

Also, if trying to upgrade to a newer ITMS version, the following errors were reported by Symantec Installation Manager (SIM) during the Installation Readiness Checks (IRC):

RunInstallReadinessCheck - exception during execution.
Invalid class 
   [System.Management.ManagementException @ System.Management]
   ....omitted....

Management Exception details: code=InvalidClass (0x80041010)
 ClasPath: __ExtendedStatus
 [Description]=[]
 [Operation]=[ExecQuery]
 [ParameterInfo]=[select TotalPhysicalMemory from Win32_ComputerSystem]
 [ProviderName]=[WinMgmt]
 [StatusCode]=[]

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   ....omitted...

Error 1:

Service check failed for: AeXSvc

Invalid class 
   [System.Management.ManagementException @ System.Management]
   at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
   at System.Management.ManagementObject.Initialize(Boolean getObject)
   at System.Management.ManagementBaseObject.get_Properties()
   at System.Management.ManagementBaseObject.GetPropertyValue(String propertyName)
   at Altiris.NS.Generated.WMI.Service.get_ProcessId()
   at Altiris.NS.ServiceSupport.ServiceController.GetServiceProcess(String serviceName)
   at Altiris.NS.SupportServices.ServiceMonitor.IsServiceRestartRequired(ServiceRestartData data)
   at Altiris.NS.SupportServices.ServiceMonitor.CheckServices(Thread me, Int32 version, ICollection`1 services)

Management Exception details: code=InvalidClass (0x80041010)

Exception logged from: 
   at Altiris.NS.SupportServices.ServiceMonitor.CheckServices(System.Threading.Thread, Int32, System.Collections.Generic.ICollection<Altiris.NS.ServiceSupport.AltirisRegistrySettings+ServiceRestartData>)
   at Altiris.NS.SupportServices.ServiceMonitor.PerformWork()
   at Altiris.Diagnostics.Threading.DiagnosticsThreadRunner.PerformWakeup()
   at Altiris.Diagnostics.Threading.DiagnosticsThreadRunner.PerformLoop(System.Threading.Thread, Int32, System.Threading.WaitHandle[], Int32)
   at Altiris.Diagnostics.Threading.DiagnosticsThreadRunner.RunnerThreadProc()
   at System.Threading.ThreadHelper.ThreadStart()

User [CORP\cmssvc], AppDomain [AltirisSupportService.exe]

-----------------------------------------------------------------------------------------------------
Date: 2/3/2020 11:47:05 AM, Tick Count: 7474078 (02:04:34.0780000), Size: 1.76 KB
Process: AltirisSupportService (13028), Thread ID: 14, Module: AltirisSupportService.exe
Priority: 1, Source: ServiceMonitor

Error 2:

RunInstallReadinessCheck - exception during execution.
Invalid class 
   [System.Management.ManagementException @ System.Management]
   at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
   at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()
   at InstallReadinessChecks.Ram.GetRAM()
   at InstallReadinessChecks.Ram.RunInstallReadinessCheck(InstallReadinessCheckStrings& installReadinessCheckStrings, Hashtable stringResources)
   at Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents, Boolean applyCriticalFixesAutomatically)

Management Exception details: code=InvalidClass (0x80041010)
 ClasPath: __ExtendedStatus
 [Description]=[]
 [Operation]=[ExecQuery]
 [ParameterInfo]=[select TotalPhysicalMemory from Win32_ComputerSystem]
 [ProviderName]=[WinMgmt]
 [StatusCode]=[]

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents, Boolean applyCriticalFixesAutomatically)
   at Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

-----------------------------------------------------------------------------------------------------
Date: 2/3/2020 11:58:31 AM, Tick Count: 8159906 (02:15:59.9060000),  Size: 2.16 KB
Process: SymantecInstallationManager (3152), Thread ID: 40, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.InstallReadinessCheckRunner.RunCheck

Error 3:

RunInstallReadinessCheck - exception during execution.
Invalid class 
   [System.Management.ManagementException @ System.Management]
   at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
   at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()
   at InstallReadinessChecks.OsW2K16.RunInstallReadinessCheck(InstallReadinessCheckStrings& installReadinessCheckStrings, Hashtable stringResources)
   at Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents, Boolean applyCriticalFixesAutomatically)

Management Exception details: code=InvalidClass (0x80041010)
 ClasPath: __ExtendedStatus
 [Description]=[]
 [Operation]=[ExecQuery]
 [ParameterInfo]=[SELECT * FROM  Win32_OperatingSystem]
 [ProviderName]=[WinMgmt]
 [StatusCode]=[]

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.InstallReadinessCheckRunner.RunCheck(IList`1 selectedComponents, Boolean applyCriticalFixesAutomatically)
   at Symantec.Installation.Context.WizardProcess.ReadinessCheckManager.DoInstallReadinessChecks()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

-----------------------------------------------------------------------------------------------------
Date: 2/3/2020 11:58:31 AM, Tick Count: 8160390 (02:16:00.3900000),  Size: 2.10 KB
Process: SymantecInstallationManager (3152), Thread ID: 40, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.InstallReadinessCheckRunner.RunCheck

Environment

ITMS 8.x

Cause

This error is caused by issues with WMI causing this error: 

Management Exception details: code=InvalidClass (0x80041010)

In this particular instance, Win32_Processor, Win32_WMISetting, and Win32_OperatingSystem were "Invalid Classes" under WMI as seen here:

Confirm WMI is Broken:

  1. Launch the WMI MMC snap-in by Start -> Run -> then enter WMIMGMT.MSC
  2. Right-click WMI Control (Local) and click Properties
  3. Check for errors under "Failed to initialize all required WMI classes" (as shown in the above screenshot).

Resolution

This is an issue that needs to be addressed by Microsoft.

A possible workaround to address this problem with WMI can be found in the following article:

https://www.virtuallyboring.com/microsoft-wmi-invalid-class-error-0x80041010/