Microsoft Office on Mac OSX fails to send calendar invites

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Article ID: 184858

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Updated On:

Products

Data Loss Prevention Endpoint Prevent

Issue/Introduction

While using Microsoft Office on Mac OSX the calendar invites will fail to send.

Behavior may be inconsistent. For example, invites may only fail for some users but not all. Other times it may only fail if the subject field is left blank.

Cause

Beginning in Outlook for Mac version 16.23.1 (19032603), Outlook uses the Outlook REST Calendar APIs to create meetings in Exchange Online. While using DLP with this change, the sequence of events that need to be performed to properly create the online meeting are disrupted. The result is that the meeting is not properly created on the server and this leads to the failure to properly send the invite.

Environment

Outlook 16.23.1 and later

Resolution

Development is aware of this issue and is working to address it in a future release.

Workarounds:

  1. Use a preference key to revert outlook back to EWS mode

An Administrator can deploy the preference key AdminCalShareOFF to the user’s system.  This will prohibit Outlook from using the Outlook Calendar REST APIs.  This preference key must be in place before the profile is created.  Administrators wishing to deploy this preference key must deploy it and have the user’s Outlook profile recreated for it to take effect.  Using this key will revert Outlook back to using Exchange Web Services (EWS) to create meetings.  By doing so, Outlook will not be using the new Calendaring Sharing model along with its improvements as outlined in Calendar sharing in Office 365 found here: https://support.office.com/en-us/article/calendar-sharing-in-office-365-b576ecc3-0945-4d75-85f1-5efafb8a37b4

Note that this removes the ability to view another users’ availability.

  1. Disable the DLP Outlook channel for Mac agents

In the console go to Settings > Agents > Agent Configuration. Modify the applicable agent configuration and uncheck the option for Outlook. Save the configuration then apply the configuration to the agent group. The agent will update the settings during the polling interval and the issue should no longer occur.