Mac computers are not in the "Unix/Linux/Mac Computers requiring Symantec Management agent upgrade" policy, while they require an update

book

Article ID: 184773

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

"Unix/Linux/Mac Computers requiring Symantec Management agent upgrade" policy is not showing any computer while many computers need to be upgraded.

Cause

"Unix/Linux/Mac Computers requiring Symantec Management agent upgrade" default filter, is excluding "Legacy UNIX/Linux/Mac Computers" in the filter. 

If you check the "Unix/Linux/Mac Computers requiring Symantec Management agent upgrade" filter, you will find "Filters excluded in this filter (1): Legacy UNIX/Linux/Mac Computers" in the Explicit Exclusions pane. 

 

This situation appeared because on Mac machine installed agent of version 8.1.5223, which is 8.5 RU2. Mac OS 10.13 is not supported by 8.5 RU2, that's why it is reported incorrectly. Most probably, the agent was installed on this machine when OS was, for example, 10.11, and then OS was upgraded to 10.13. So basically when the machines are upgraded to a newer unsupported version of Linux/Unix the agent can fall into this category. So the fix is either hack the filter and be done or make sure you only install the agent on supported versions.

Resolution

  • Clone the filter "Unix/Linux/Mac Computers requiring Symantec Management agent upgrade"
  • Remove "Legacy UNIX/Linux/Mac Computers" Explicit Exclusions, that nothing be excluded.
  • Now all mac computers requiring upgrade would show up.
  • Create a new target using this filter, and add it to the "Symantec Management Agent for UNIX/Linux/Mac - Upgrade" policy targets.