Failure staging data from ActiveDirectoryDW
search cancel

Failure staging data from ActiveDirectoryDW

book

Article ID: 184749

calendar_today

Updated On:

Products

Information Centric Analytics Data Loss Prevention Core Package

Issue/Introduction

The job step Run Staging Procedures (4) of the RiskFabric Processing job fails and logs the following error in both the SQL Server Agent job history and in the RiskFabric table dbo.Log_DataTransformation:

Login Failed for user '[<domain>\]<account>'. Reason: Failed to open the explicitly specified database 'ActiveDirectoryDW'. [CLIENT:<local machine>]

Environment

Version : 6.x

Component : RiskFabric Processing

Cause

This typically occurs when the SQL Server Agent service account has been changed from NT Service\SQLSERVERAGENT (for the default instance) or NT Service\SQLAgent$<instance-name> (for named instances) to a local or domain user that has not been assigned the sysadmin role in SQL Server and does not have permissions to access the ActiveDirectoryDW database.

Resolution

Configure the SQL Server Agent to run under the appropriate NT Service account for the SQL Server instance; grant the db_owner privilege on the ActiveDirectoryDW database to the local or domain account under which the SQL Server Agent is running; or grant the sysadmin role to the local or domain account under which the agent is running.