"Limit run duration" values in Control Compliance Suite query scheduling does not save values

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Article ID: 184717

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

In trying to set the value of the "Limit run duration" setting in the schedule section of a Control Compliance Suite (CCS) query job, the value chosen does not save.

 

No error displayed but when job is edited the value for this field is now reset to zero.

 

Cause

Console code defect.

 

Environment

CCS 12.0 through 12.5.0

 

Resolution

The "Limit run duration" function is limited to jobs involving standards.  Unfortunately this field is being displayed in error in the query job type (not involving a standard) and is being ignored by the code.

CCS 12.5.1 (planned to be released in November of 2019), will correct this issue and have additional features giving similar control to run durations, but at an even more granular level.  Until upgrading to version12.5.1, the funtionality of a limit to a run duration is not available in queries.