Enforce upgrade from 15.5 to 15.5 MP1 fails

book

Article ID: 184714

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

You are performing an upgrade on Data Loss Prevention (DLP) Enforce server on Linux from 14.6 to 15.5 and then to 15.5 MP1. The upgrade to 15.5 portion has finished successfully, but during an attempt to upgrade to 15.5 MP1 you are unable to ran the EnforceServerUpdateConfigurationUtility.

 

 

Cause

During upgrade from 14.6 to 15.5 new /etc - response.varfile - is created, without any data inside. Upgrade to 15.5 is completed successfully. But when you run EnforceServerUpdateConfigurationUtility to upgrade to 15.5 MP1, response.varfile is filled in with outdated Oracle hostname and SID information. 

 

Environment

Data Loss Prevention (DLP) Enforce server on Linux platform. 

 

Resolution

This article assumes that jdbc.properties, tnsnames.ora, $ORACLE_HOME have correct data. 

Workaround:
1. Modify the /opt/SymantecDLP/.install4j/response.varfile manually with correct oracleHost and oracleSID entries.
2. Run EnforceServerUpdateConfigurationUtility.