DLP AD User Group Indexing is Failing with the "Include Mail Aliases" box checked

book

Article ID: 184670

calendar_today

Updated On:

Products

Data Loss Prevention

Issue/Introduction

When trying to index an AD User Group from within the DLP Enforce Console with the "Include Mail Aliases" checkbox checked, the index will fail. This is happening whether it is reindexed on a schedule or manually when checking the "Refresh group directory index on Save" checkbox in the User Group.

Data file was corrupted (Creating Index Version xxx)

Cause

The issue is caused by a defect in the IncrementalMembershipMapper class.

Environment

DLP Version 15.1 and beyond.

Resolution

Workaround:

Uncheck the "Include Mail Aliases" checkbox within ALL User Groups in the DLP Enforce Console, save the groups, and then reindex. The error should now be gone.

 

Fix:

DLP 15.7

DLP 15.5 MP2

Additional Information