Task server fails to complete registration - Authentication failed, server refused to authenticate with provided credentials
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Article ID: 184650
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Updated On:
Products
IT Management SuiteTask Server
Issue/Introduction
After upgrading to a newer ITMS release version, you noticed that your Task Servers fail to register. In this situation, Task Servers had an account 'xxxx' which was a local account on both the SMP and Site Server.
Error entries:
Error code: HTTP status 401: The request requires user authentication (0x8FA10191)
Error note: Authentication failed, server refused to authenticate with provided credentials
Error note: Authentication failed, server refused to authenticate with the provided credentials or the user account is locked
Environment
ITMS 8.x
Cause
Account used did not have correct permissions.
Recent Management Platform Upgrade
Resolution
Issue 1)
Navigate to this setting to validate if the credentials are correct:
Select "Use Application Credentials" instead of "Use these credentials"
If step 2 is successful, there may be an issue with the Agent Connectivity Credential as specified. If the Account is on a Domain, the Domain must be referenced. i.e. Domain\UserName
Issue 2)
The SMP was recently upgraded and the Task Servers do not have the new Symantec Management Agent and the updated Task Services install. Do the following:
Enable the SMA Upgrade for Site Servers
Settings > All Settings > Agents/Plugins > Symantec Management Agent > Windows > Site Server > Symantec Management Agent for Windows XXX (SIte Server Only) - Upgrade
Enable the Task Service Upgrade Policy
Settings > All Settings > Notification Server > Site Server Settings > Task Service > Advanced > Task Service Upgrade (XXX)