Task server fails to complete registration - Authentication failed, server refused to authenticate with provided credentials

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Article ID: 184650

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Updated On:

Products

Management Platform (Formerly known as Notification Server) Task Server

Issue/Introduction

After upgrade from 8.1 to 8.5 release, Task Server fails to register. In this situation, Task Server had an account 'xxxx' which was a local account on both the SMP and Site Server.

Error code: HTTP status 401: The request requires user authentication (0x8FA10191)

Error note: Authentication failed, server refused to authenticate with provided credentials

Error note: Authentication failed, server refused to authenticate with the provided credentials or the user account is locked

Cause

Account used did not have correct permissions.

Environment

ITMS 8.x

Resolution

  1. Navigate to this setting to validate if the credentials are correct:
    • Console > Setting > All Settings > Agents/Plug-ins > Symantec Management Agent > Settings > Global Agent Settings > Authentication (Tab) > Agent Connectivity Credential
  2. Select "Use Application Credentials" instead of "Use these credentials"

If step 2 is successful, there may be an issue with the Agent Connectivity Credential as specified.  If the Account is on a Domain, the Domain must be referenced.  i.e. Domain\UserName