Detection servers in an Unknown state in the Enforce console after an upgrade

book

Article ID: 184469

calendar_today

Updated On:

Products

Data Loss Prevention Network Prevent for Email

Issue/Introduction

Symantec Data Loss Prevention (DLP)
Network Prevent for Email

Detector (NP for Email) upgraded from DLP 14.6 to DLP 15.1and doesn't communicate with Enforce server.
Detector server on console shows up with status Unknown.

Unknown Status

File: debug/BoxMonitor0.log
Date: 12/27/2018 7:37:51 PM
Class: com.vontu.communication.transport.ServerChannelManager
Method: <init>
Level: SEVERE
Message:  failed to init server channel channel manager
java.net.BindException: Cannot assign requested address: bind
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)

Cause

Communication.properties configuration file configured with a serverbindname=IPAddress and host to IP address mapping is not configured at the server C:\Windows\System32\Drivers\etc\hosts file, and java.net.PlainSocketImpl.socketBind(Native Method) is configured to bind tcp port 8100 to a host that doesn't exist in the hosts file.

Environment

DLP 15.1, Windows Server 2012 R2

Resolution

Comment the serverbindname=IPAddress line in the Communication.properties under the C:\SymantecDLP\Protect\config directory as shown bellow.

 

Attachments