Duplicate Communication Profiles for SMP or Task Server show error: '' contains the same FQDN and web application path"
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Duplicate Communication Profiles for SMP or Task Server show error: '' contains the same FQDN and web application path"

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Article ID: 184468

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

When viewing SMP / Site Server Communication Profiles in the Symantec Management Console, some of them are duplicated:

Settings > Agents / Plug-ins > Symantec Management Agent
  OR if it's a Site Server, expand Site Server Communication profiles

Users are unable to delete (right-click > delete) duplicate communication profiles on their SMP.

May see the following under the duplicate communication profile settings: 

Existing profile 'name of the server' contains the same FQDN and web application path. Existence of non-unique profiles can lead to connection problems if some outdated profile will be used by the NS agent.

Environment

ITMS 8.x

Cause

During the disaster recovery process or an off-box upgrade, another "built-in" SMA profile may be created.

Upgrading sometimes causes another profile to be created as well.

Resolution

Find the GUID: IF the Communication Profile is VISIBLE in the Console

Browse to Settings > Agents / Plug-ins > Symantec Management Agent Communication Profiles
OR if it's a Site Server, expand Site Server Communication profiles

    1. Identify the correct duplicate profile (be sure that this profile is not currently in use by agents/site servers)
    2. Right-click on the communication profile and select "Properties"
    3. Copy the GUID of the communication profile
    4. Paste the following query into SQL and run, replacing the capitalized section with the appropriate GUID:
          Update Item
          set Attributes = Attributes - (current value of Attributes)    -- result of this query is that Attributes = 0
          where Guid = 'GUID OF PROFILE TO DELETE

      Make sure that Attributes = 0: 

          select Attributes , * from Item
          where Guid = 'GUID OF PROFILE TO DELETE


    5. Go back to the communication profile page, refresh, and try to right-click and delete the profile
    6. If right-click > Delete does not work, make sure the Attributes for the GUID is 0, and then skip to the bottom section.

 

Find the GUID: IF the Communication Profile is NOT visible in the console

IF the Communication Profile is not visible in the Console, your error message may say: Existing profile '' contains the same FQDN and web application path.  This indicates that the Communication Profile does not have a name in the database and so it is not visible in the Console. 

    1. To find these Duplicate Profiles run this SQL Query (exactly as shown):

select Name, GUID, State, *
from item
where State like '%<Name of the server FQDN or profile having issue>%'
order by 1

Search through the list to find the Communication Profile that does not have a name.  Then continue with steps below.

 

Delete the GUID

A) Once you find the GUID set it's attribute to 0 and add it to the ItemToDelete table (deletes happen every 15 minutes on the NS.Quarter Hour Task schedule)

Update Item
set Attributes = Attributes - (current value of Attributes)    -- result of this query is that Attributes = 0
where Guid = 'GUID OF PROFILE TO DELETE' 

B) Then:

insert into ItemToDelete 
select  guid, GETDATE() 
from item where guid = 'GUID OF PROFILE TO DELETE'

C) After the NS.Quarter Hour schedule runs the item will be removed from the database.

Additional Information

171409 "Unable to delete duplicate or conflicting Symantec Management Agent communication profiles"