Unable to connect registry to standalone IAM during upgrade.

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Article ID: 184122

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Updated On:

Products

CLOUDTEST CA Application Test CA Cloud Test Mobile MOBILECLOUD Service Virtualization

Issue/Introduction

We tried upgrading E1 registry to 10.5 from 10.2 version, we have a separate IAM server configured, and we are trying to upgrade registry however its failing to connect to IAM url during setup. below are the error logs. The same url is accessible on browser that means IAM is up and running.

 

java.lang.RuntimeException: Could not obtain configuration from server [https://localhost:51111/auth/realms/service_virtualization/.well-known/uma-configuration].

        at org.keycloak.authorization.client.AuthzClient.<init>(AuthzClient.java:92)

        at org.keycloak.authorization.client.AuthzClient.create(AuthzClient.java:60)

        at com.ca.ad.sv.iam.IAMClient.<init>(IAMClient.java:42)

        at com.ca.devtest.acl.internal.IAMClientFactory.createIAMClient(IAMClientFactory.java:21)

        at com.ca.devtest.acl.internal.IAMClientFactory.getIamClient(IAMClientFactory.java:13)

        at com.ca.devtest.acl.internal.IAMUtil.pingIAM(IAMUtil.java:35)

        at com.itko.lisa.coordinator.TestRegistryImpl.initialize(TestRegistryImpl.java:279)

 

Cause

In lisa.properties iam.server.url property is set to localhost:

Environment

Release : 10.5

Component : CA Service Virtualization

Resolution

 Edit  the below properties in  lisa.properties. 

iam.server.url=https://localhost:51111/auth

to 

iam.server.url=https://<IAMhost>:51111/auth