Search results not returned as expected.

book

Article ID: 182908

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

When using "Not Equals" rules in a CA Identity Manager (IM) Search Screen no results are returned.

Cause

Previous builds of CA Identity Manager (IM) supported the use of "NOT_EQUALS" allowing it to return an empty result set, however it was seen to cause a performance impact and was consequently removed, subsequently if an empty result set was identified processing stopped and search filters are not applied.   

Environment

Release : 14.1 CP10

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Resolution

Workaround (If you wish to return an empty result set)

Previous Filter :

"employeeType NOT_EQUAL SAP Roles"


New Filter:

"employeeType NOT_EQUAL SAP Roles"

OR

"employeeType NOT_EQUAL * "

Attachments