Client Automation - Delay in camping due to apipa address
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Client Automation - Delay in camping due to apipa address

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Article ID: 182876

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Updated On:

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Software Delivery CA Client Automation - Remote Control

Issue/Introduction

camping to a scalability server or Domain Manager has bad response time or fails with timeout.
There are sometimes delay of more than 6 seconds

Example :




Environment

Client Automation - All versions

Cause

This problem could have multiple cause (cam is overloaded, network congestion etc...)

But one possible cause is if there are these 2 following conditions :

- In file %CAI_MSQ%\cam.cfg on scalability server (or Domain Manager) there are this line :

disable_proxies = yes


- In output of command "camstat -n" on scalability server/Domain Server there are some APIPA address (private IP address with range 169.254.0.1 to 169.254.255.254)

Example :

Host                  proto state  port  Qlen  m/sent  m/recv  retry  disc  RTO
--------------------- ----- ----- ----- ----- ------- ------- ------ ----- ----
169.254.244.165         udp   ---  4104     0       0       0      4     1    1
169.254.132.33          udp   ---  4104     0       0       0      4     1    1




Some machines are using the APIPA address for communication with its scalability Server. As disable_proxies is set to YES, Scalability Server does not used the correct IP Address and communicate with Agent using its APIPA address. And this does not work as it is a private IP Address.

This is causing a delay of 3 seconds in cam.


Example :

08:39:36.413  send_message(): Seq 12077086, XX, from Vxxxxx/U-CAF, to 169.254.66.124/CAI003796-00014, len 4962, data >...<, created 34613, life 0, notify: yes, flags: 1, src 10.x.y.z, dst 169.254.66.124
08:39:39.397  set_next_udp_queue() called



cam hangs during 3 seconds trying to send a message to APIPA address. This is causing delay in the sending of CAM messages to others Agents

Resolution

2 possible solutions :

- Remove "disable_proxies = yes" line in %CAI_MSQ%\cam.cfg on scalability server/Domain Manager

1- Edit file %CAI_MSQ%\cam.cfg and remove the line

disable_proxies = yes


2- Restart caf and cam

caf stop
camclose
caf start



Or (if remove of disable_proxies = yes is not a valid solution) :


- Disable APIPA on Windows machines.

This could be done do this by adding a DWORD parameter in registry :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\IPAutoconfigurationEnabled = 0

See this for example :
https://www.itprotoday.com/windows-78/how-can-i-disable-apipa


It is possible to do this via an AM Job (scheduled to run only once) of type command containing a command like :
reg ADD "HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters" /v IPAutoconfigurationEnabled /d 0 /f /t REG_DWORD