Unable to run pdm_configure after copying an MDB from a Production Environment to Development or Test Environment
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Unable to run pdm_configure after copying an MDB from a Production Environment to Development or Test Environment

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Article ID: 18152

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Updated On:

Products

CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When copying a Service Desk mdb database from one Service Desk environment to another, or when changing the hostname of an existing Service Desk server and running a pdm_configure, the following message is displayed:

Already following servers are using same Database

 

 

Environment

This error can occur in an environment where the 'Swing Box' method of upgrade is being used. It may also be seen when running a pdm_configure in an environment where a clone of an existing Service Desk system is being created or when the hostname of the Service Desk server has been changed.

Cause

The pdm_configure process compares the server name in the usp_servers table in the mdb with the one entered in the Primary Server node in the General Settings section of the pdm_configure. If these names differ the message is displayed. The message references the name of the server that this mdb database was previously configured for.

Resolution

Using either SQL Management Studio, or SQLPlus (or any other db mangement tool) for Oracle, set the value of the "del" field on all rows in the usp_servers table to have a value of "1".  Make sure you have taken a backup of the given database and the usp_servers table first before making this change.

Then run pdm_configure on the Primary or Background server.

This will add that server (which you ran pdm_configure on) to the usp_servers table.

If you your Test/Dev environment has Secondary servers, or if you are using Advanced Availability, you will now need to log into Service Desk Manager on the Primary or Background server and re-add any Secondary servers, or Standby servers and App servers that you have in your Test/Dev environment.

Next, you will need to edit the configuration that is being used to ensure you have the appropriate daemons configured on each of those servers.

Once you have completed the server configuration, you will then need to run pdm_configure on any Secondary servers, or Standby servers and App servers that you have in your Test/Dev environment.