Unable to regain connectivity to SQL Database following SQL Server restart / NSSetup wizard prompt.

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Article ID: 180884

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

 

Resolution

Problem
Unable to regain connectivity to SQL Database following SQL Server restart / NSSetup wizard prompt.

NOTE: Inetpub folder contains the wwwroot folder.  

To reproduce error:

  1. System working normally.
  2. User moves Inetpub folder.
  3. System continues to work normally.
  4. Altiris service is stopped and started, such that the NS Setup runs when the NS Console is accessed, as it is now recognized that the config has changed.
  5. Running through NS Setup reveals error: "Failed to check the selected SQL Server Version" as the NS is unable to connect to SQL.

The error also occurred when changing the NS to point to another Database Server when it was previously pointing to an on-box database, after SQL Server was removed from the NS server.

Environment
NS 6
IIS, any version
SQL, any version

Cause
User moved the "Inetpub" folder from the default location.  Problem manifested when Altiris services were restarted and then NS Console is accessed.  Since DB was not ready, the NS Setup page started.

Resolution
Resolved issue by stopping IIS (iisreset /stop) and Altiris Services.  Moving the \Inetpub folder back to the default location (See IIS > Default Website properties > Home Directory tab > Local Path), restarting IIS and Altiris Services.

Console then loaded normally.