Problem/Symptoms |
|
Some of the cubes in the Client Server Management pack appear to be displaying duplicate data.
|
Environment
|
|
This issue is isolated to the following environment:
|
Cause
|
|
When IT Analytics processes data from the configured CMDBs, it is not hierarchy aware. The data in each CMDB is processed fully into each cube. If you have multiple client facing Symantec Management Platform servers as well as a top tier Symantec Management Platform that serves as an Asset Management Server, you can prevent data duplication by excluding the Asset Management Server from processing the Inventory cube, Patch Management cube, etc.
|
Resolution
|
|
IT Analytics Service Pack 2 (build number 7.1.2060) introduces a new feature that enables you to configure which CMDBs should be processed for different sets of cubes. This functionality allows you to explicitly exclude the Asset Management CMDB from being processed for any of the inventory based cubes. In order to use this new feature, you must first make sure you have IT Analytics Service Pack 2 installed. The build number for IT Analytics Service Pack 2 is 7.1.2060.
Once IT Analytics Service Pack 2 is installed, you can configure the cube inclusion settings by navigating to IT Analytics Settings > Connections > Symantec CMDB.
If you would like to utilize the Cube Inclusion functionality for the local CMDB that IT Analytics is installed on, you must treat it as an external CMDB. In this case on the Connections > Symantec CMDB page under Local Symantec CMDB Connection select the second radio button “Do not include the Symantec CMDB configured for this Symantec Management Platform”. Then you can configure an external Symantec CMDB connection to the local CMDB and that will allow you to manage the cube inclusions for the CMDB.
|