Convert Installshield Scripts into Wise Package Studio .MSIs

book

Article ID: 180076

calendar_today

Updated On:

Products

Symantec Products

Issue/Introduction

 

Resolution

Question
I have the task of changing an InstallShield Script to Wise.  The Installshield files were built in InstallShield 10 Professional.  How can I use Wise Package Studio's tool (Wise Installer Editor)  to import this version of InstallShield scripts?

Answer
You can use the Convert InstallShield® Professional tool to convert an installation script project (.IPR) that was created in version 5.5 or later of InstallShield Professional to a Windows Installer package.

Guidelines
Because InstallShield Professional installations are based on a different technology than Windows Installer, not all elements of the source installation are converted to Windows Installer format:

The installation is built from the configuration files defined by the .IPR. Files, registry keys, and shortcuts are converted. The Product Name, Product Version, and Company Name properties are also converted. File source paths are retained.

The .RUL file, which controls how the resources are installed, cannot be converted. Add custom actions to the new package to replace any custom logic that was previously stored in the .RUL file.

Only InstallShield projects that use English in their dialogs can be converted.

All the files available to the original InstallShield installation must be available to the converted Windows Installer package at the same locations.

Resources are organized into features based on groups in the resource lists. To retain the organization in the InstallShield project, components are organized into separate features, with FileGroups as child features.

To convert an InstallShield Professional installation:
1. Do one of the following:

Select File menu > New. On the New Installation File dialog, select Conversion Tools from the Categories list and double-click InstallShield Professional in the Templates/Tools list. (In Visual Studio: Select File menu > New > File. On the New File dialog, select Wise Files from the Categories list and double-click Convert InstallShield Professional in the Templates list.) Use this method to create an installation that contains only the information from the converted installation.

Select Tools menu > Convert InstallShield® Professional. (In Visual Studio: Project menu > Convert InstallShield® Professional.) Use this method to add the converted installation's information to the current installation file.

The Welcome dialog appears.

2. On the Welcome dialog, specify the full pathname of the project file (.IPR) to convert.

3. Click Next to start the conversion.

The Conversion Progress dialog appears. The .IPR file is converted to Windows Installer format.

When the conversion is finished, the Conversion Complete dialog appears. It displays the results of the conversion and lists any errors or problems that might have occurred. (Example: If files referenced by the source installation could not be found, an error is displayed.) You can fix these problems in Installation Expert and Setup Editor.

4. To obtain a record of the conversion errors, click Save Errors or Print Errors.

5. Click Finish.

More errors might appear at this point, which have to do with saving in Windows Installer format.

The installation that was created from the .IPR file opens. Pages in Installation Expert (example: Files page) are populated based on the contents of the source installation.

If a file that is part of a merge module is added, the Files in Merge Modules dialog appears. It prompts you to add the merge module and, if necessary, download it. See Adding Merge Modules Instead of Files.

Please note that Wise Package Studio only works with the IPR file format.  ISM is not currently supported