Patch Management: PMImport task takes up to 8 hours to complete

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Article ID: 179995

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

 

Resolution

Problem

Important: The following article applies to Notification Server 6.0 SP2 only.

The PMImport process for Patch Management Solution takes a long time to run—up to 8 hours to complete or more.

Environment
Notification Server 6.0.5287 (SP2)
Patch Management 6.1

Cause

PMImport taking a long time to run is essentially due to a bottleneck in SP2.

The DeleteList that is processed as part of PMImport is taking an extraordinary amount of time. The underlying problem is that whenever a ResourceAssociation is deleted, there are some underlying tables that also get updated through the use of a SQL trigger. In SP2 these tables are

  • ResourceAssociationHist
  • ResourceAssociationHistDelta
  • ResourceAssociationSnapshot

Resolution

Run the following query in SQL Query Analyzer. This will add an Index to the ResourceAssociationSnapshot table and will greatly increase the speed of the PMImport task.

CREATE INDEX [idxSnapshotId] ON [dbo].[ResourceAssociationSnapshot]([SnapshotId])

Note: This is not applicable to SP3, as the ResourceDelete mechanism has been significantly overhauled.