Receive error "No package could be found for the selected agent installation policy" when attempting to push out the Software Management Solution Plug-in

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Article ID: 179853

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Updated On:

Products

Software Management Solution

Issue/Introduction

 

Resolution

Problem
Unable to push out the Software Management Solution Agent for Windows Plug-in.

When the customer tries to open the policy it throws an error stating:

"No package could be found for the selected agent installation policy."

Environment
Symantec Management Platform 7.x

Software Management Solution 7.x

Cause
Unknown corruption with the installation.

Resolution

Verify that the agent install packages exist in Manage > All Resources > Packages > Software Packages.  Searching for "Software Management" should list 3 packages: 32bit, 64bit, and Mac.

  - If the packages do not exist, perform a repair of Software Management Solution through SIM.  If this does not resolve the issue, contact Symantec Support so functional install files can be obtained.

  - If the packages do exist, perform a reconfigue of the Software management Solution with AeXConfig as follows

1.  Open a command prompt and navigate to C:\Program Files\Altiris\Notification Server\Bin 

2.  Run AeXConfig /configure "C:\Program Files\Altiris\SoftwareManagementSolution\Config\SoftwareManagementSolution.config"

Note: Paths listed are for a default installation.  These paths will change if SMP is installed in a nonstandard location.