Why am I seeing duplicate MAC addresses when viewing Collections?

book

Article ID: 179814

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

 

Resolution

Problem
When viewing Collections, I seem to have hundreds of computers showing the same MAC address.

Environment
Notification Server 6.0

Cause

PPP/SLIP interfaces created by Microsoft dial-up connections will use one of two MAC addresses (44-45-53-54-00-00 or 00-53-45-00-00-00).  

The spGetComputerResources Stored Procedure creates the Collection template and uses the vComputer View to obtain the data.  The vComputer View extracts data from various Tables, one of them being the Inv_AeX_AC_TCPIP.  Its syntax for this Table is as follows:

LEFT OUTER JOIN
dbo.[Inv_AeX_AC_TCPIP] tcp
ON tcp.[_ResourceGuid] = r.[Guid]
AND tcp.[_id] =
(SELECT TOP 1 t.[_id]
FROM [Inv_AeX_AC_TCPIP] t
WHERE r.[Guid]=t.[_ResourceGuid]
AND t.[IP Address] NOT IN ('127.0.0.1', '0.0.0.0', '')
AND NOT t.[IP Address] IS NULL)

As this syntax displays the top most record for each resource, which is the lowest Id in the Table, there is a limited chance that the correct MAC Address for the NIC that is being used will be displayed.  Many customers have informed us that this causes duplicate MAC Addresses being displayed in all Collections.

Resolution
Additional syntax was created that can be added to the vComputer query which will prevent VPN MAC addresses from being displayed and is as follows:

AND t.[MAC Address] NOT IN ('44-45-53-54-00-00', '00-53-45-00-00-00', '') AND NOT t.[MAC Address] IS NULL

Which means that the full Inv_AeX_AC_TCPIP will now be:

LEFT OUTER JOIN
dbo.[Inv_AeX_AC_TCPIP] tcp
ON tcp.[_ResourceGuid] = r.[Guid]
AND tcp.[_id] =
(SELECT TOP 1 t.[_id]
FROM [Inv_AeX_AC_TCPIP] t
WHERE r.[Guid]=t.[_ResourceGuid]
AND t.[IP Address] NOT IN ('127.0.0.1', '0.0.0.0', '')
AND NOT t.[IP Address] IS NULL
AND t.[MAC Address] NOT IN ('44-45-53-54-00-00', '00-53-45-00-00-00', '')
AND NOT t.[MAC Address] IS NULL)

Bear in mind that a repair of the Notification Server, a reconfiguration of the database or an upgrade of the Notification Server may replace this View with the original one, so check this after these procedures just in case you have to modify the View again.

Symantec is working towards a mechanism for Notification Server 7 which will allow the Notification Server Agent to identify the NIC that it uses to communicate with the Notification Server, in a similar fashion than that of Deployment Solution.