What criteria are checked to determine "Product is not properly configured" in SIM?

book

Article ID: 179649

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

 

Resolution

Question
What criteria are checked to determine "Product is not properly configured" in SIM?

Answer
 

The following answer is provided as reference since explaining in detail how SIM works and how it determine a proper configured product will require a very technical document.


1. When SIM starts the installation process, it makes a Windows API call to start the MSI installation.
2. When the MSI is done installing, the API process returns a status with the execution value.
3. When all the MSIs are installed, SIM makes a call to a Webservice to do configuration. This webservice process is owned by the NS Platform process.
4. When the product being configured is done, the Webservice returns a status. SIM queries that status and determinates if it has been done based on the status returned.
5. SIM queries the database in order to check what appears as configured. SIM uses the information contained in the database and compares the Product Listing:

--Query 
 select [State] from vProductInstallation --(SIM searches what’s returned from State for the MSI’s product code—if found, SIM reports the product as configured)


In most cases this failure to configure is caused by the Altiris Services failed to start in a timely fashion, causing the configuration to fail.
Only reason the status on the SIM main page will report ‘not configured’ is because the MSI’s product code is not found in the query of the State column.
 

This can be caused by two things:
1)
the configuration did actually fail, which should have been reported at the end of the installation/configuration of a product. This usually happens, as it is mentioned above, because there were problems with the webservice; and  this can be fixed by running “aexconfig /configureall”. Usually running "aexconfig /configureall" should be enough to fix that.


2) The MSI’s product code and the product code listed in the config file do not match. In this case SIM will never report the product as configured because the above query will never find the correct product code in the State column (which comes from the config file). In this case the product may very well be configured.

Another case is that the configuration was completed just fine but SIM reports that it didn't happen. In those cases the issue is with a mismatch between the product code guid in the config file and the MSI. If that is the case, no matter if you try to reconfigure it will still show as unconfigure. Usually the Solution team that owns the MSI needs to fix the product listing.

Running a repair on the Solution using SIM does not trigger a reconfiguration as It only runs a repair on the MSI.

 

Related Resources

SIM shows "Product is not properly configured" or "Partial installation"
http://www.symantec.com/business/support/index?page=content&id=TECH122207