Symptoms:
Team object's audit trail records are only displayed after you 'Save' the configuration AGAIN in Studio, Object, Audit Trail tab
Steps to Reproduce:
- Login as an administrator user
- Administration, Studio, Objects, go to the Team object
- Go to the Audit Trail tab
- Select 'Open' (Open for Time Entry) field for "Audited Attributes" and Click 'Save' or 'Save and Return' button
- Create/Open a project instance and go to Team Staff page
- Add a new team staff member
- Open this Staff Member Properties page and update 'Open for Time Entry' field and Save
- Go to Audit tab
Note: If you are not able to recreate the issue... try adding a new staff member again and repeat the steps.
Also select other attributes for Auditing only UPDATE operation (Do not audit Insert/Delete operations)
Expected Results: The Audit Trail should show the audit records for the changes made.
Actual Results: No audit trail records are displayed
Cause:
Caused by CLRT-68810
Resolution:
Resolved in CA PPM 14.1
Workaround:
- Administration, Studio, Objects, go to the Team object
- Go to the Audit Trail tab
- Click on 'Save' button again...
- Go back to Staff Member Properties, Audit tab. Audit records are now shown properly.