Outbound message not delivered due to invalid HELO name
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Outbound message not delivered due to invalid HELO name

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Article ID: 178171

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Updated On:

Products

Messaging Gateway

Issue/Introduction

  • Sender receives error: 550 Helo command rejected: Email denied due to invalid helo name.
  • Nslookup on the sender domain returns a valid MX record.
  • The MTA host name on the Symantec Messaging Gateway is different from the outbound MX record.
     

550 Helo command rejected: Email denied due to invalid helo name.

Environment

Messaging Gateway

Cause

Some Mail Transfer Agents (MTA) will perform a Reverse DNS lookup to verify the sender hosts identity. If the sender MTA host name is other than the name listed in the public MX record, the message could be rejected.

 

Resolution

The MTA host name must match the MX record.
To verify with the recipient domain if reverse DNS is used by their mail services, contact their administrator or public help documents.

To change the MTA host name on your SMG via Control Center:

  1. Navigate to Administration -> Hosts -> Configuration.
  2. Select the appropriate host.
  3. Navigate to SMTP -> Advanced Settings.
  4. Change the MTA Host Name at the top of the box to match your public MX record.
  5. Click Continue.
  6. Click Save.